آسیب پذیری های کشف شده وردپرس (December 2020)

دسته بندی: اخبار, امنیت, وردپرس
باگ های وردپرس دسامبر 2020
آنچه در این مطلب می‌خوانید :
آسیب‌پذیری‌های کشف شده در پلاگین‌های وردپرس

در آخرین ماه میلادی سال ۲۰۲۰ نیز همانند ماه‌های گذشته، آسب پذیری‌هایی در افزونه‌ها و قالب‌های وردپرس کشف شده است. مهمترین و خطرناک‌ترین آسیب‌پذیری کشف شده، در پلاگین Contact Form 7 است و در رابطه با جزییات آن می‌توانید اینجا را مطالعه کنید.

در مقاله امروز، سایرآسیب‌پذیری‌های کشف شده در قالب‌ها و افزونه‌های وردپرس را بررسی می‌کنیم. با ما همراه باشید.

آسیب‌پذیری‌های کشف شده در پلاگین‌های وردپرس

در این بخش آسیب‌پذیری‌های کشف شده در ۱۷ تا از فزونه‌های وردپرس را مرور می‌کنیم.

آسیب‌پذیری CSRF در پلاگین Site Offline

این آسیب پذیری به دلیل عدم وجود یک توکن برای بررسی CSRF، این اجازه را به هکر می‌دهد تا با کنترل administrator برخی تغییرات را در بخش تنظیمات این پلاگین اعمال کند.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۴.۴ و ما قبل آن

آسیب‌پذیری Unauthenticated Insecure Deserialisation در پلاگین Newsletter Manger

یک مشکل Deserialization ناامن در این پلاگین، منجر به اجرای حمله PHP object injection خواهد شد.

نسخه‌های آسیب‌پذیر در این پلاگین: تا این لحظه تمامی نسخه‌ها آسیب پذیرند.

آسیب‌پذیری XSS در پلاگین LiteSpeed Cache

در این پلاگین IP های نامعتبری که در صفحه Toolbox آن دریافت می‌شود، قبل از نمایش پیغام خطا به درستی فیلتر نمی‌شوند؛ همین امر اجازۀ اجرای حمله Stored XSS رابه هکر می‌دهد.

حتما بخوانید:  آموزش بک آپ گیری در وردپرس از طریق هاست و افزونه

نسخه‌های آسیب‌پذیر در این پلاگین: ۳.۶.۱ و ما قبل آن

آسیب‌پذیری XSS در پلاگین WP Postratings

به دلیل عدم فیلتر در پارامتر postratings_image امکان سواستفاده از آن و اجرای حمله Stored XSS وجود خواهد داشت.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۸۶.۱ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Envira Gallery Lite

این پلاگین image metadata به طور صحیح را قبل از نمایش خروجی آن فیلتر نمی‌کند و به کاربران با دسترسی editor به بالا امکان اجرای حمله XSS بر روی بازدیدکنندگان سایت که گالری را مشاهده می‌کنند، خواهد داد.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۸.۳.۳ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Simple Social Buttons

در ورژن ۳.۲.۰ این پلاگین در پارامتر share_counts آسیب پذیری XSS کشف شد و اقدام به رفع مشکل با اضافه کردن یک CSRF check کردند اما همچنان آسیب پذیری برای کاربران unauthenticate وجود داشت. برای حل این مشکل در نسخه جدیدتر آن فیلترهای بیشتری قرار دادند.

نسخه‌های آسیب‌پذیر در این پلاگین: ۳.۲.۱ و ما قبل آن

آسیب‌پذیری Unrestricted File Upload در پلاگین Contact Form 7

در ماه گذشته در پلاگین محبوب Contact Form 7 آسیب پذیری خطرناکی کشف شد که به هکر امکان آپلود فایل‌ها و WebShell های مخرب را می‌دهد. جهت مشاهده گزارش کامل این آسیب پذیری، می‌توانید مقاله زیر را بخوانید.

نسخه‌های آسیب‌پذیر در این پلاگین: ۵.۳.۲ و ما قبل آن

آسیب‌پذیری CSRF در پلاگین Redux Framework

در این پلاگین به دلیل اینکه nonce اعتبارسنجی تنها در صورتی که در request وجود داشته باشد بررسی می‌شود، امکان دور زدن آن وجود دارد و می‌توان حمله CSRF را اجرا کرد.

نسخه‌های آسیب‌پذیر در این پلاگین: ۴.۱.۲۳ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Limit Login Attempts Reloaded

این پلاگین ورودی‌های کاربر در صفحه option را به درستی فیلتر نمی‌کند و همین موضوع منجر به اجرای حمله Reflected XSS می‌شود. این حمله در صورتی اجرا می‌شود که مدیر سایت در پیشخوان وردپرس login باشد و لینک مخربی را باز کند.

نسخه‌های آسیب‌پذیر در این پلاگین: ۲.۱۶.۰ و ما قبل آن

آسیب‌پذیری Login Rate Limiting Bypass در پلاگین Limit Login Attempts Reloaded

هکر می‌تواند با تغییر header ها در هنگام ارسال درخواست، محدودیت‌هایی که در Origin مربوطه اعمال شده است را دور بزند.

حتما بخوانید:  رفع آسیب پذیری احراز اصالت در MongoDB

نسخه‌های آسیب‌پذیر در این پلاگین: ۲.۱۷.۴ و ما قبل آن

آسیب‌پذیری Unauthenticated Backup Download در پلاگین Total Upkeep by BoldGrid

در این پلاگین، دسترسی به فایل‌های حساس و مهم (مانند مسیرهای بکاپ) به درستی محدود نمی‌شود و هر کاربری می‌تواند آن‌ها را مشاهده و دانلود کند.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۱۴.۱۰ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Directories Pro

این پلاگین به درستی اسم ستون‌ها را هنگام import کردن یک فایل CSV فیلتر نمی‌کند و می‌تواند منجر به حمله Self XSS شود.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۳.۴۶ و ما قبل آن

آسیب‌پذیری Reflected XSS در پلاگین Directories Pro

به دلیل عدم فیلتر مناسب در پارامتر the_drts_form_build_id در درخواست POST، هکر می‌تواند کدهای HTML و جاوا اسکریپتی خود را تزریق کند.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۳.۴۶ و ما قبل آن

آسیب‌پذیری CSRF در پلاگین Ultimate Category Excluder

در این پلاگین به دلیل عدم بررسی CSRF token در صفحه options، هکر قادر به اجرای حمله CSRF بر روی کاربران login شده خواهد بود.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۲ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Pagelayer

چند آسیب‌پذیری Reflected XSS در پارامترهای font-size و color در این پلاگین کشف شده است که در نسخه جدید آن این موارد برطرف شده است.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۳.۵ و ما قبل آن

آسیب‌پذیری SQL Injection در پلاگین DiveBook

پارامتر filter_diver در صفحاتی که DiveBook ،embed شده است، به درستی ورودی‌های کاربر را فیلتر و اعتبارسنجی نمی‌کند و باعث اجرای حمله SQL Injection خواهد شد.

نسخه‌های آسیب‌پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب‌پذیری XSS در پلاگین DiveBook

در این پلاگین آسیب پذیری Reflected XSS کشف شده است و به واسطه آن هکر می‌تواند یک لینک آلوده با کدهای جاوا اسکریپت را به قربانی ارسال کند و با باز کردن آن توسط قربانی، این حمله اجرا شود.

نسخه‌های آسیب‌پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب‌پذیرند.

آسیب‌پذیری Improper Authorisation Check در پلاگین DiveBook

به دلیل یک نقص امنیتی در Add New Dive که یک feature در این پلاگین محسوب می‌شود، به کاربران غیرمجاز امکان ایجاد یک dive entery جدید با HTTP POST request جعلی می‌دهد.

حتما بخوانید:  حملات بروت فورس چیست و راهکار جلوگیری از Brute Force

نسخه‌های آسیب‌پذیر در این پلاگین:تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب‌پذیری Log Disclosureدر پلاگین Easy WP SMTP

این پلاگین قابلیت debug log file دارد که در فولدر پلاگین ذخیره و نگهداری می‌شود و شامل تمام ایمیل‌های ارسالی است. اگرچه این فولدر صفحه index ندارد، اما در صورت وجود misconfiguration و آسیب‌ پذیری directory listing امکان دسترسی به لاگ‌ها فراهم می‌شود.

این موضوع می‌تواند به هکر امکان دسترسی به یوزر admin بلاگ را با ریست کردن پسورد آن و خواندن لینک password reset از طریق لاگ‌ها بدهد.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۴.۳ و ما قبل آن

آسیب‌پذیری XSS در پلاگین Themify Portfolio Post

این آسیب‌پذیری از نوع Stored بوده و کاربران با سطح دسترسی Contibutor و بالاتر، امکان تزریق کدهای مخرب جاوا اسکریپت یا HTML را در پست‌ها خواهند داشت.

نسخه‌های آسیب‌پذیر در این پلاگین: ۱.۱.۶ و ما قبل آن

آسیب‌پذیری SQL Injection در پلاگین Profile Builder و Profile Builder Pro

پارامتر orderby در صفحه زیر در صورتی که Email confirmation در تنظیمات این پلاگین فعال باشد، به درستی ورودی‌ها را کنترل و فیلتر نمی‌کند و با استفاده از آن می‌توان حمله Blind SQL Injection را اجرا کرد. این آسیب پذیری توسط کاربران سطح بالا مانند administrator قابل پیاده‌سازی است.

wp-admin/users.php?page=unconfirmed_emails&orderby=email&order=asc

نسخه‌های آسیب‌پذیر در این پلاگین: ۳.۳.۳ و ما قبل آن

آسیب‌پذیری‌های کشف شده در تم‌های وردپرس

این ماه ۲ آسیب‌پذیری در تم Listingpro کشف شده است که در ادامه آن‌ها را بررسی می‌کنیم.

آسیب‌پذیری Sensitive Data Disclosure در تم Listingpro

به واسطه این آسیب‌پذیری هر کاربری می‌تواند با ارسال یک request مانند درخواست زیر، به اطلاعات حساسی مانند نام‌های کاربری، ایمیل‌ها و … دسترسی داشته باشد.

/wp-admin/index.php?download-lp-users=yes

نسخه‌های آسیب‌پذیر در این تم: ۲.۶.۱ و ما قبل آن

آسیب‌پذیری Unauthenticated Arbitrary Plugin Installation/Activation/Deactivation در تم Listingpro

کاربران غیرمجاز امکان نصب، فعال کردن و غیرفعال کردن پلاگین‌های دلخواه خود را خواهند داشت.

نسخه‌های آسیب‌پذیر در این تم: ۲.۶.۱ و ما قبل آن

حرف آخر

اگر صاحب یک وب‌سایت وردپرسی هستید، هرچه سریع‌تر نسبت به به‌روزرسانی افزونه‌ها و قالب‌های گفته شده اقدام کنید و راه نفوذ هکر را ببنید، تا دچار هک و از دست رفتن اطلاعات‌تان نشوید.

اگر این مقاله برای‌تان مفید بود، آن را برای دوستان وبمسترتان بفرستید.

۱+
برچسب ها:

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Fill out this field
Fill out this field
لطفاً یک نشانی ایمیل معتبر بنویسید.
You need to agree with the terms to proceed

همچنین شاید دوست داشته باشید!

فهرست