امنیت

باگ امنیتی افزونه WordPress Elementor Pro ؛ همین حالا به روز رسانی کنید!

طبق گزارشی که شرکت Wordfence – مالک افزونه امنیتی قدرتمند Wordfence – ارائه کرده است افزونه WordPress Elementor Pro در نسخه های قبل از ۲٫۹٫۴ آسیب پذیری های بحرانی در کدهای خود دارد که دسترسی هک وردپرس را فراهم می کند. این آسیب پذیری هنگامی قابل سوء استفاده است که قابلیت ثبت نام یا Registration در وردپرس فعال شده باشد. اگر هکر بتواند در قالب هر کاربر ثبت نام شده فایل های دلخواه خود را روی سایت آپلود کند میتواند کنترل آنرا از راه دور در دست بگیرد و … بوم!

همچنین Wordfence در گزارش فوق تاکید میکند که اگر از Ultimate Addons for Elementor روی همان سایت استفاده می کنید امکان سوء استفاده از یک آسیب پذیری مجزا روی Ultimate Addons for Elementor وجود دارد که می تواند خود Ultimate Addons را به عنوان کاربر ثبت نام شده برای Elementor Pro جا بزند و چون در بالا گفتیم کاربران ثبت نام شده امکان آپلود فایل دلخواه و هک سایت را دارند پس، کسانی که از Ultimate Addons for Elementor در کنار Elementor Pro استفاده می کنند نیز وضعیت مشابهی دارند.

برای رفع این مشکل باید گام های زیر طی شود:

۱) به روز رسانی هسته وردپرس، Elementor Pro و Ultimate Addons for Elementor

۲) همون طور که می بینید سایر المان های وردپرسی اگه قدیمی و آسیب پذیر باشند قابلیت نفوذ اولیه رو به هکر نیز می دهند، دیگر المان های قدیمی و آسیب پذیر را هم به روز رسانی کنید.

۳) استفاده از افزونه های امنیتی قوی مانند Wordfence و Sucuri.

برگرفته از [wordfence.com]

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

بستن