وضعیت سرورها

وبــلاگ

وضعیت سرورها
  • آسیب پذیری Dirty COW در سرور های CentOS

    سینا حامد حیدری پنج شنبه ۶ آبان ۱۳۹۵ امنیت , لینوکس

     

    fffi

     

    درتاریخ ۱۰/۱۹/۲۰۱۶ آسیب پذیری امنیتی در هسته (kernel) سیستم عامل لینوکس با نام اختصاری dirty COW منتشر شد. این باگ به دلیل وجود مشکل در هنگام مدیریت عملیات copy-on-write توسط هسته COW نام گزاری شده است. در واقع این باگ از سال ۲۰۰۷‌ و در هسته های ورژن ۲٫۶٫۲۲ و بالاتر وجود داشته است. خوشبختانه اکثر توزیع های لینوکس بسته های امنیتی جدیدی در آخرین آپدیت های خود برای رفع این باگ ارائه داده اند.

    این باگ باعث می شود که یک کاربر با سطح دسترسی محدود توانایی ویرایش فایل هایی را داشته باشد که تنها کاربر root به آنها دسترس دارد، بدین ترتیب یک کاربر با دسترسی های محدود می تواند خود را تبدیل به admin سیستم عامل نماید.

    بررسی آسیب پذیری

    در برخی از نسخه های CentOS از طریق اجرای دستورات زیر می توانید وجود این آسیب پذیری را بررسی نمایید:

    wget https://access.redhat.com/sites/default/files/rh-cve-2016-5195_1.sh

    bash rh-cve-2016-5195_1.sh

    اگر سرور شما آلوده باشد، خروجی شبیه پیغام زیر مشاهده خواهید کرد:

    Your kernel is 3.10.0-327.36.1.el7.x86_64 which IS vulnerable.

    Red Hat recommends that you update your kernel. Alternatively, you can apply partial

    mitigation described at https://access.redhat.com/security/vulnerabilities/2706661 .

     

    رفع مشکل

    به منظور رفع مشکل هرچه سریعتر سیستم عامل خود را به روز نمایید. در صورتیکه می خواهید تمام پکیج ها را به روز نمایید از دستور زیر استفاده نمایید:

     yum update -y

    و در صورتیکه می خواهید فقط هسته سیستم عامل را به روز نمایید دستور زیر را اجرا نمایی:

     yum update kernel -y

    در نهایت سرور خود را با دستور زیر ریستارت نمایید:

    reboot

    در نسخه centos 7 نیازی به ریبوت نمی باشد.

    0

    برچسب ها :

با عضویت در خبرنامه شما را از آخرین تجربیات مان و مطالب تخصصی آگاه خواهیم کرد.

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *