وضعیت سرورها

وبــلاگ

وضعیت سرورها
  • چه Loaderهایی از PHP 5.4 پشتیبانی می‌کند

    محسن معتمدیان یکشنبه ۱۰ فروردین ۱۳۹۳ تازه‌ها , لینوکس , معرفی نرم‌افزار , مقالات , نکته‌ها

    با توجه به اینکه در باره ارائه PHP 5.4 و فواید ارتقا به PHP 5.4 صحبت نمودیم، در این مقاله قصد داریم Loaderهایی که از PHP 5.4 پشتیبانی می‌کنند را معرفی کنیم.

    ۱. Zend Guard Loader:

    چه Loaderهایی از PHP 5.4 پشتبانی می‌کند

    شرکت Zend Technologies برای نسخه ‫PHP 5.3 لودر معروف خود به نام Zend Optimizer را ارائه نداد، بلکه برای نسخه‌های  ‫PHP 5.2 به بعد لودر جدیدی با نام Zend Guard معرفی نمود.

    بنا به گزارش Zend Technologies این دو لودر جز نسخه PHP تفاوت دیگری با هم ندارند، همچنین این شرکت به کسانی که با Zend Optimizer مشکل دارند گفته‌است باید اسکریپت خود را به PHP 5.3 و لودر Zend Guard بروزرسانی کنند.

    Loaderهای Zend Technologies و نسخه‌های هماهنگ PHP با آن:

        * Zend Guard loader برای نسخه‌های ۵٫۳ تا PHP 5.4

            فایل‌های که با Zend Guard در نسخه‌های PHP 5.2 و PHP 5.3  کد شده‌اند در صورت ارتقاء نسخه PHP به PHP 5.4 دیگر قابل اجرا نخواهند بود و باید مجددا فایل‌ها کد گذاری شوند.

        Zend Optimizer loader برای نسخه‌های ۴٫۲ تا PHP 5.2

           شرکت zend نسخه Zend Guard 6 را آماده کرده‌است، این نسخه PHP 5.3 و PHP 5.4 را پشتبانی می‌کند و در صورت ارتقاء نسخه PHP به نسخه PHP 5.4 باید نسخه Zend Grund را نیز به نسخه ۶ ارتقاء داد و مجددا فایل‌های را کد کرد.

    پشتیبانی Zend Guard از نسخه‌های PHP
    Zend Guard 5.5 PHP 5.3 و PHP 5.2
    Zend guard 6 PHP 5.4 و PHP 5.3

    ۲٫ ionCub Loader:

    چه Loaderهایی از PHP 5.4 پشتبانی می‌کند

    ionCube 4.5.3 جدیدترین نسخه ارائه شده ionCube است که از PHP 5.4 پشتیبانی می‌کند. فایل‌هایی که با نسخه‌های ۴٫۰٫۰ به بعد کد گذاری شده‌اند در صورت ارتقا به نسخه PHP 5.4 قابل اجرا هستند و با مشکلی مواجه نمی‌شوند.

    ۳٫ SourceGuardian Loader:

    چه Loaderهایی از PHP 5.4 پشتبانی می‌کند

    این شرکت جدیدترین نسخه SourceGuardian که نسخه ۹٫۵ می‌باشد را ارائه کرده‌است که از PHP 5.4 پشتیانی می‌کند. فایل‌هایی که با نسخه‌های ۴٫۰٫۰ به بعد کد گذاری شده‌اند در صورت ارتقا به نسخه PHP 5.4  قابل اجرا هستند و با مشکلی مواجه نمی‌شوند.

    در جدول زیر لیست نسخه‌های SourceGuardian و نسخه‌های PHPای که توسط آن پشتیبانی می‌گردد را مشاهد خواهید کرد.

    پشتیبانی SourceGuardian از نسخه‌های PHP
    SourceGuardian V4 PHP 4.3 و PHP 4.4
    SourceGuardian V5.0 PHP 5.0 و PHP 5.1
    SourceGuardian V5.1 PHP 5.0 و PHP 5.1
    SourceGuardian V5.2 PHP 5.2
    SourceGuardian V5.3 PHP 5.3
    0

    برچسب ها :

با عضویت در خبرنامه شما را از آخرین تجربیات مان و مطالب تخصصی آگاه خواهیم کرد.

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *